Critical Error with Images


Discourse Version: 3.2.0.beta2-dev ( 7019dbcfe1 )

Plugin Commit: 2.4.23 d5aa616

Steps to Reproduce

When a wizard has an uploaded image nothing happens when you click done and I see the following in the console. I can post an image the normal way.

Another user reported seeing this error “You supplied invalid parameters to the request: Category not allowed for topic creation.” but I am not seeing this.

I haven’t changed anything except for updating to the latest build yesterday, then the problems started.

Uploading: CleanShot 2023-10-02 at 07.56.25@2x.jpg…


I can give admin access to anyone working on this


The only weird thing I’m seeing in the logs:

Sidekiq is consuming too much memory (using: 510.87M) for ‘’, restarting

config/unicorn.conf.rb:164:in check_sidekiq_heartbeat' config/unicorn.conf.rb:244:in master_sleep’
unicorn-6.1.0/lib/unicorn/http_server.rb:295:in join' unicorn-6.1.0/bin/unicorn:128:in <top (required)>’
/var/www/discourse/vendor/bundle/ruby/3.2.0/bin/unicorn:25:in load' /var/www/discourse/vendor/bundle/ruby/3.2.0/bin/unicorn:25:in

Edit: FYI the image of the console I attached here did not come through with the wizard either, I had to edit and add it.

I couldn’t reproduce this on my own test environment and since you said you had an issue here as well, I tried to create a bug report with an uploaded image.

That worked fine (see here for the - now unlisted - topic)

Long story short, I’m unable to repro.

Indeed, there seems to be something bigger going on unrelated to the wizard that is causing everyone to not be able to create topics in certain categories. My image issue here must have been a fluke.

(Related Cannot Create New Topics - support - Discourse Meta)

Do you have any categories where the topic create button starts a wizard instead of the composer?

That’s something that was recently changed and it’s definitely where that error is coming from

Yes indeed, I have a lot of my categories using this feature, and I think it’s the ones that are missing from the list if you reference my post on meta. Where do I find the setting now? It seems to be missing from the category settings?

Edit: Nevermind, I found the setting. I tried removing the wizard from the category setting, and now it shows up in the list. So yes, this is a major bug.

Also, the category settings are very buggy now. The reason I couldn’t find it was because it wasn’t showing up, I had to refresh the page to see it. Also when you change categories within the settings, the selected wizard does not show until you refresh the page.

1 Like

I can repro those buggy category settings. Same problem with the dropdown for journal.
I guess this needs an observer or a @discourseComputed @jumagura

Let’s go back to the original problem and let’s see if I can summarize it correctly.

You are unable to post in categories that have the custom wizard set to replace the new topic composer. (That’s desired behavior although we recently fixed a bug!)
But you also have problems uploading images in the same categories?

1 Like

The image upload was a red herring, please ignore that. I thought this was the case because another wizard that didn’t have an upload was working, but that’s because that category did not have a wizard set in the category settings.

So the real issue is simply having a wizard set in the category prevents the wizard from finishing when you hit done and the errors in the console I posted before are relevant. When I disable the wizard in the category settings and then go to the wizard directly, it works as expected. Maybe there’s a conflict with another plugin, I’ll do some investigation on another site in the meantime.

1 Like

FYI I am unable to reproduce that on this forum.

Interesting, I can repro on my test site which I have disabled all other plugins: Exploring Exposure

Also, the Action type needs to be set to Create Topic in the wizard

exploring-exposure-wizards-1696277117.json (542 Bytes)

Bug Fix Update

Dear @davidkingham

We’ve addressed the issue related to the category ID mismatch during topic creation, which was inadvertently introduced in a previous update.

Fix Details:

  • Necessary adjustments have been made to the logic to handle topic creations correctly.

Next Steps:

  1. Update to the latest version of the plugin to apply this fix.
  2. Feel free to test topic creation in categories with wizards to ensure it works as expected.

We apologize for any inconvenience this may have caused. If you encounter further issues or have any questions, please feel free to reach out.


3 posts were split to a new topic: Cannot change topic of category with wizard as composer