When selecting a language in the Content Language Selector, the Topic List is not filtered as expected.


Discourse Version: 3.1.0.beta4 ( 9858171f3c )

Plugin Commit: 59049eb2

Steps to Reproduce

  1. enable and set up content languages
  2. tag some topics with different content language tags
  3. try to select a language tag from the content languages drop down
  4. it doesn’t filter as expected



The resource https://lisaoflife.com/assets/onpopstate-handler-ece5c756a2e952d484f91ce9faefcf87d7660f2102e26047221987c335ff8c11.js was preloaded using link preload but not used within a few seconds from the window’s load event. Please make sure it has an appropriate as value and it is preloaded intentionally.

1 Like

Actually, we looked at this in more depth, and I think it’s basically not broken, it’s simply not that intuitive. The documentation should be improved. I’d forgotten how it works and had to remind myself by looking at the code.

The resulting list of language tags are not selected individually but are used as the set of language tags that determine what topics are shown.

So clicking on a single language tag in the drop down doesn’t appear to filter the topic list by that specific tag and nor is this intended:

As an Admin, if you wish to use the whole Topic List as a way of checking through for untagged content languages, you must first clear the Content Language selection from your User Preferences.

I think the actions here should be:

  • improve the documentation.
  • document the functionality as part of a front end test.

tagging this as #low


I reported the same on Meta, it’s a kind of ‘not’ from UI/UX perspective (!)

With full respect, I don’t feel that’s #low because transmit the sentiment the plugin don’t work.

And that push eventually customers away (probably fits better on #mid or something)

There is a better workaround than hide the not-filter :grimacing: from CSS?

1 Like

yeah, it probably should be a different kind of control

1 Like