Users in process of completing wizard after signing up cannot view other pages


Discourse Version: v3.1.0.beta8 +417

Plugin Commit: fee56c2d

Steps to Reproduce

  1. Have a wizard with following setting checked: “Users directed to wizard after signup.”
    We do not have “Users cannot skip wizard” checked.

  2. Wizard contains links to topics in some forums, in order to help users complete the wizard.

  3. Last couple of users have complained that clicking on these links, which used to take them to the topic, now just redirects them to the original wizard, making the topics unreadable. (Asking the user to try in an incognito window works.)




Are you sure? That version of the CW plugin is not compatible with that Discourse version.

I am also unable to reproduce this behavior on fee56c2d with latest tests-passed.

EDIT however, I have signed up at your forum and I can reproduce it there. Would you be able to share the wizard json ( in a PM if you don’t want to make it public) ?


My apologies, it looks like you’re right. I think I might have accidentally copy/pasted the discourse version from the Upgrades page, but from the wrong column. The correct version is 3.2.0.beta1-dev (8ef569cda4).

Please let me know if the behavior is fixed if I update to the most recent of everything, that would be great! (Hate to bother you guys over this, but it definitely didn’t previously work this way.)

I previously shared it very recently on this thread: , is it something you can access?

Yes, I can access that. You seem to be pretty much on the most recent of everything already.

So I can indeed reproduce the behaviour, as long as I don’t try in an incognito window (which was what I previously did).

OK cookie solution won’t work because new tabs inherit cookies (doh!)


I’ve added a back door so that you can specify a query parameter in a link and which will prevent redirect on first paint:

So, for example the following link will open in new tab and avoid an immediate redirect. Any subsequent navigation will redirect:

<p>Check out <a href="http://localhost:4200?ignore_redirect=1" target="_blank">forum</a>.</p>

I think that’s a good enough solution @Richard @angus ?

1 Like

That’s quite brilliant @merefield .

1 Like

This solution is now merged. (thanks for review @angus).

@evenrue I performed a successful Production checkout and this works.

Please be aware of the new system … if you want to link people to a Topic within your Wizard to which they will have been redirected, you must put ?ignore_redirect=1 as a querystring parameter in your link.

so, e.g.:

<p>Check out <a href="" target="_blank">forum topic on this subject</a>.</p>

This is a one-shot. They will arrive at the desired link and will not be redirected, but if they attempt to change page from there, they will be.

The change was required as the original solution was a lucky outcome but too fragile to survive a more robust redirection logic refactor.

Please update CW and confirm this solution works.

1 Like

Hi, @merefield .

Thanks so much. I have updated and can confirm that the additional parameter is working/helping. Appreciate your attention to this matter.

1 Like

My pleasure. And that’s great news!

I will close this topic but if you have any problems please open a new one.