Location input fields don't seem to work on the user profile

I discovered this while trying to get Locations and the Custom Wizard Plugin to play nicely.

In the Locations plugin itself the location input fields don’t appear to be working at all in the user profile. I’m talking about this:


When I tick location_input_fields_enabled, nothing changes. I still have the single entry box in /my/preferences/profile:



This of course might be intentional (i.e. the setting only applies to Topics, not Users) - if so it would be helpful to have this made clear.

I believe this to be the case, but agree this could be more clear.

For as long as I can remember, User Location entry in Profile has always been a “one-liner” single entry.

I’ve just taken a look - there sure are a lot of translation files to change in order to change the text associated with that setting!!

Is there a shortcut to doing that? This is what I thought might work:

Enable location input fields (topic locations only)

But I can totally understand if that isn’t worth the significant trouble!!

1 Like

Oh we can just change “en” and I think there may be some automation to cover the rest.

1 Like

The shortest PR in the world:

1 Like

Followed by potentially the shortest review in the world :wink:

Thanks @nathank … it’s running checks atm


OK to close this?

1 Like